XIM-405 - Business customers unable to create transactions

Incident Report for Xe

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 13:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 08, 2025 - 13:45 UTC

Investigating

We are currently experiencing a partial outage.

We are investigating and will provide an update as soon as possible.

Apologies for any inconvenience.
Posted Oct 08, 2025 - 13:36 UTC
This incident affected: Money Transfer Website.